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This document is the MOHID Studio Quick Start Guide for MOHID Land. It contains a 

tutorial on how to create a MOHID Land project with MOHID Studio.  

This document makes part of the MOHID Studio Documentation. 
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1 Preface 

1.1 Copyright 

This document refers to MOHID Studio, proprietary computer software which is 

protected by copyright. All rights are reserved. Copying or other reproduction of this 

document or related programs is prohibited without prior written consent of Action 

Modulers, Consulting & Technology (Action Modulers). 

MOHID Water Modelling System is proprietary software of the Instituto Superior 

Técnico (University of Lisbon). 

1.2 Warranty 

The warranty given by Action Modulers is limited as specified in your Software License 

Agreement. Please note that numerical modeling software programs are very complex 

systems and may not be free of errors, so you are advised to validate your work. 

Action Modulers shall not be responsible for any damage arising out of the use of this 

document, MOHID Studio, MOHID Water Modelling System or any related programs or 

documents. 

1.3 Further Information 

For further information about MOHID Studio please contact: 

Action Modulers, Consulting & Technology, Ltd. 

Estrada Principal, nº 29 - Paz 

2640-583 Mafra, Portugal 

Tel.: +351 261 813 660 

Fax: +351 261 813 666 

E-mail: geral@actionmodulers.com 

Web: http://www.actionmodulers.com 
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2 Quick Start Tutorial for MOHID Land 

This “Quick Start Tutorial for MOHID Land” is intended to help first-time users creating 

their first projects, following a sample project, an implementation in a small 

watershed, the Trancão Watershed, near Lisbon, Portugal. 

It is suggested that you follow the tutorial, which progresses with increasing 

complexity, trying to replicate the provided sample project. After finished exploring all 

simulations with the samples, it is suggested that you revisit the tutorial applying the 

model examples to your own study site. 

The tutorial starts with a preconfigured sample project, which is downloaded from 

Action Modulers’ web site, so you can get used to MOHID Studio’s environment, 

including projects and simulation structure, graphical visualization, running the model. 

All these tasks can be performed without any previous knowledge about using MOHID 

Studio / MOHID Land.  

After the first play-around you are invited to independently create a simple 

hydrological project forced with rain, preparing the topography (include basin 

delineation), prepare the input files, run the model and explore results as previously.  

The tutorial then shows how to access more complete example covering full 3D 

simulation with river discharges and meteorology, sediment transport, point sources 

and nutrient transport and transformation (full water quality simulation), resulting in a 

quite complete simulation that can be run with MOHID Land. 

For each step, the require options to configure the model are explained in detail.  

This is intended to be a step-by-step tutorial to implement in a straightforward way a 

MOHID Land project from simpler to complex simulations. Detailed description of the 

governing equations used by the model is not provided in this guide; neither a detailed 

description of the processes solved by the model is provided. For further information 

about these topics, you should explore the following MOHID related sources: 

Action Modulers website – http://www.actionmodulers.com 
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MOHID website – http://www.mohid.com/ 

MOHID wiki – http://wiki.mohid.com/wiki 

MOHID forum – http://www.mohid.com/forum/ 

MOHID code repository – https://github.com/Mohid-Water-Modelling-System/Mohid 

It is assumed that you have installed already MOHID Studio (following MOHID Studio’s 

Installation Guide) and that you understand the functioning of the different windows, 

environments and buttons (following MOHID Studio User Guide). 

This manual applies to MOHID Studio 2016 (version 3.0).  

In order to complete all steps in this document, you must have a Professional or an 

Evaluation License. 

 



M O H I D  L a n d  Q u i c k  S t a r t  

 
A c t i o n  M o d u l e r s  -  w w w . a c t i o n m o d u l e r s . c o m  4  

 

3 Exercise 1 - Explore a previously configured project 

3.1 Introduction 

The tutorial starts by providing a sample project so you can get familiarized to MOHID 

Studio. You will use a previously configured project and produce results with it.  

3.2 Preparation 

For Exercise 1, please prepare your PC the following steps: 

1. Create a directory C:\MOHID Land Quick Start Guide1 

2. Create a directory C:\MOHID Land Quick Start Guide\Temp 

3. Create a directory C:\MOHID Land Quick Start Guide\Projects 

Download the demo project from the link below and store it in the “temp” directory 

created in 2.  

� http://www.actionmodulers.com/Downloads/TrancaoSimple.zip 

Please do not “unzip” this file, since MOHID Studio is expecting a ZIP file. 

Now your directory should look like shown in the next figure. 

 

 

                                                      

1 You can alternatively create this structure on a different disk (e.g. D:\) 
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3.3 Start MOHID Studio and import the preconfigured 

example 

Start MOHID Studio by selecting Start -> Action Modulers -> MOHID Studio 2016. 

 

You can alternatively use the icon on your desktop. 

 

For this example, we have to create a new workspace. After MOHID Studio started, 

please select Home -> Workspace -> Open from MOHID Studio’s main menu. 
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MOHID Studio’s Workspace Manager Window appears which allows you to create a 

new work space. Choose “Start with an empty Workspace” and name it “MOHID Land 

Quick Start Guide”. 

 

Figure 3.1: MOHID Studio Workspace Manager 

Press ok to close the window. 

Now we will import the previously configured example. Please select Project -> 

Solution -> Manage. 
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MOHID Studio’s “Solution Management” window appears (Figure 3.2). 

 

Figure 3.2: MOHID Studio Solution Management 

In this window press the button “Import”, located on right. The window “Import 

MOHID Solutions” will appear. 

 

Figure 3.3: The Import MOHID Solution window 
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Select Solution Type “MOHID Studio” and under “Project File Name” browse for the 

file previously downloaded and stored in the “temp” directory (“C:\MOHID Land Quick 

Start Guide\Temp\TrancaoSimple.zip”). 

The “Destination Directory” must be an empty directory. Please create a directory 

called “Trancao Simple” in “C:\MOHID Land Quick Start Guide\Projects”). You can to 

this after clicking the button, as shown in the next figure.  

 

Figure 3.4: Creating the destination directory 

Once you are done, the “Import MOHID Solutions” window should look like the one 

shown next. 

 

Figure 3.5: MOHID Studio Import Solution 
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Press the import button ( ) and wait until the import process is complete. 

 

Figure 3.6: Message informing that the import process has finished 

Close the message box and the “Import MOHID Solutions” window. In the “Solution 

Management Window” you should see now the imported solution, like shown next. 

 

Figure 3.7: MOHID Studio Solution Management (after import) 

NOTE: If a solution with the same name of the solution to import already exists, the 

newly imported solution is automatically renamed (example: Trancao Simple_1). Close 

this window also. 

Now we have to open the solution we just imported and associate it to the current 

workspace, by selecting Project -> Solution -> Open. 

 

The “Create or Open Solution” window appears with the solution “Trancao Simple”, 

like shown in the next figure. 
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NOTE: The “Create or Open Solution” window looks very similar to the “Create 

Workspace window”. The differences between workspaces and solutions are explained 

in the user manual. 

 

Figure 3.8: The “Create or Open Solution” window 

In this window select “Open an existing solution” and select the “Trancao Simple”. 

Press “OK” to close the window. 

This action will open the “Trancao Simple” solution in “Explorer” tab. Press on the 

triangles ( ) to expand the tree view in the “Explorer”. You screen should now look 

like shown in the next figure. 
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Figure 3.9: MOHID Studio’s Explorer window after importing and opening the “Trancao Simple 

Project” 

Step 2 – Navigating in the project structure  

Like all MOHID Studio solutions, this solution is divided into the following items: 

the root element – the “Solution” 

one or more “Domains”, in this case the “Trancao Simple”. 

special folders for storing data common to all simulations 

simulations to run specific scenarios. 

In the middle of the explorer window you will find the “Modules”. By selecting any 

item in the “Project Tree”, the “Modules” in the middle of the explorer window will be 

updated. For example, if you select the simulation “Sim #1 Impermeable Watershed”, 

your window shows the data files associated with this simulation, as shown in the next 

figure. 
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Figure 3.10: MOHID Studio’s Explorer window – Data files 

NOTE: The “Modules” are divided into 3 areas: Data Files, HDF Files and Time Series 

Files. Details about these file types are explained in the user manual. 

The project management is one of the core features of MOHID Studio. Another feature 

is the internal GIS engine, which allows you to visualize all spatial data. Next we will 

show how to visualize the digital terrain of the Trancão Simple project.  

3.4 Visualize the digital terrain of the Trancão Watershed 

Adding layers to the GIS engine can be done directly from the “Explorer”. To add the 

digital terrain of the Trancão Watershed, proceed in the following way: 

In the Project Tree select the folder “Digital Terrain” (1). This will fill the Data Files 

under “Modules”. Select the file “FinalDTM_160m_v4.dat” (2) and right click it. In the 

popup which appears select “Add to Map…” (3). Next screen shot shows these steps. 



M O H I D  L a n d  Q u i c k  S t a r t  

 
A c t i o n  M o d u l e r s  -  w w w . a c t i o n m o d u l e r s . c o m  1 3  

 

 

Figure 3.11: Selecting the bathymetry to be displayed in the map 

The window “Add Vector Layer” appears.  

 

Figure 3.12: The “Add Vector Layer” window. 

Just leave all default values as they are and press “OK”. 

NOTE: If in this step appear a message complaining about the license, you don’t have a 

valid license to proceed (MOHID Studio Professional). We encourage you to request a 

temporary evaluation license. Check MOHID Studio’s Installation Guide for more 

information. 
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Now switch to the “Map” tab to see the digital terrain in the map window. Your screen 

should look like shown in the next figure. 

 

Figure 3.13: MOHID Studio Map Window with Trancão Watershed 

To add a background map go to “Map” -> “Background Layers” -> “Tiles” (Figure 3.14).  

 

Figure 3.14: Add a background layer 

A warning appears informing you that the coordinate system of the map has to be 

changed to “Web Mercator Projections” (Figure 3.15). Click “Yes” to continue. 

 

Figure 3.15: Changing the coordinate system 

A window which lets you choose from a range of background layers will appear (Figure 

3.16). Choose “Bing – Aerial” and OK to add the layer to the map. 
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Figure 3.16: Selecting the type of background layer 

Your main window now should look like the one in the next figure. 

 

Figure 3.17: MOHID Studio with the Trancão Watershed and a background layer 

3.5 Running a simulation 

Now we will run a simulation of the sample project. Please switch back to the 

“Explorer” and in the “Project Tree” select the simulation “Sim #1 Impermeable 

Watershed” (1) and then select “Project” -> “Execute Models” -> “Run Now” (2). Figure 

3.18 shows these two steps. 
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Figure 3.18: Running the simulation Sim #1 

A window appears to confirm the execution of the model (Figure 3.19). Press “Yes” to 

continue. 

 

Figure 3.19: Confirm the execution of the simulation Sim #1 

The box window called “Model Controller” below the domains and simulations is filled 

showing the progress bar of the simulation (Figure 3.20). To check more details on the 

simulation status press “Output” button to be able to see what is the current 

simulation time, the current computer time and the expected computer time when the 

simulation will end. The “Cancel” button in the window allows you to abort the 

simulation at any time. 
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Figure 3.20: MOHID Studio Model Controller 

At the end of the simulation a window notifies the user that the model has finished.  

 

Figure 3.21: MOHID Studio Model Finished 

To see the log file of the model run select “Yes”. A window with the log of the model 

run will appear. 

 

Figure 3.22: Model run log file 
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We recommend scrolling down this window until the end, so you can verify if the 

model did end successfully (Figure 3.23). 

 

Figure 3.23: Model run log file (end of file) 

3.6 Exploring the Results 

During the simulation the model output files are created. When selecting the 

simulation that just finished running (“Sim #1 Impermeable Watershed”), the 

“Modules” section in the middle pane is filled with “HDF Files” and “Time Series Files” 

result data (Figure 3.24).  

 

Figure 3.24: Result files of the simulation Sim #1 
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HDF files contain model results for the entire computational grid at different time 

instants of the simulation, similar to instantaneous snapshots of the study area. These 

results can be plotted as maps animated in time.  

Time series files contain results for predefined computational grid points with high 

output frequency. These results can be plotter as time series graphs.  

They way how these outputs can be configured will be explained later. More 

information on how to visualize results can be found in the “MOHID Studio User 

Guide”. 

We will start with creating a time series plot of the channel flow at a place called 

“Node_Ponte_Zambujal”. For this we double click on the file 

“Node_Ponte_Zambujal.srn” in the “Time Series Files” list. This is the last of all files 

listed in this box. A window appears with a list of available time series. We choose 

“[channel flow] [MOHID Land Model] (Figure 3.25). 

 

Figure 3.25: List of time series in the file “Node_Ponte_Zambujal.srn” 

After pressing ok MOHID Studio creates a new XY Graph window with a plot of the 

selected series. Your screen should look like the one in the next figure. 
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Figure 3.26: MOHID Studio time series of the channel flow (Sim # 1) 

Now we will add the channel flow of the entire domain as animated layer to the map 

window. 

First we switch back to the “Explorer Tab” and select the simulation “Sim #1 

Impermeable Watershed” in the “Project Tree”. Then we double click on the file 

“Drainage Network_1.hdf5” in the HDF Files list. These steps are shown in the next 

figure. 

 

Figure 3.27: Displaying the channel water depth as animated layer – step 1 
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A window will appear which allows you to configure a set of options of what to display. 

Just leave all options unchanged (channel flow is the default property to display - 

Figure 3.28). 

 

Figure 3.28: Displaying the channel flow as animated layer – step 2 

Now you have to switch to the “Map” tab. On top of the digital terrain you now also 

see a layer which shows the flow in the channels. Your screen should look like the one 

shown in the next figure. 
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 Figure 3.29: Displaying the velocity modulus as animated layer – step 3 

You can now use the “Date & Time” controller, located in the lower left corner, to step 

forward and backward in time (Figure 3.30) 

 

Figure 3.30: Displaying the velocity modulus as animated layer – step 4 

Now we switch back to the “Explorer Tab” and select the simulation “Sim #1 

Impermeable Watershed” in the “Project Tree”. Then we double click on the file 

“RunOff_1.hdf5” in the HDF Files list. The same dialog as shown previously appears, 

allowing us to select which type to load as layer. 
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Just leave all options unchanged (this time water column is the default property to 

display) and press OK. Switch to the Map TAB.  

Now your display shows the water column, the flow in the channel, the DTM and a 

background layer and should look like the following figure. 

 



M O H I D  L a n d  Q u i c k  S t a r t  

 
A c t i o n  M o d u l e r s  -  w w w . a c t i o n m o d u l e r s . c o m  2 4  

 

We will organize the display. First we switch off the DTM, by unselecting the check box 

in the layer list. 

 

We also will move the “Channel Flow” layer on top of the “Water Column” layer by 

selecting it (left mouse button) and then using the context menu (right mouse button) 

to choose “Move Up”. 

 

Using again the timer to step forward in time, you can now see the channel flow and 

the water column represented as colors, as shown in the next figure. 
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There are many ways to customize how these layers are displayed. You can access the 

properties of the current selected layer by pressing “F4”. For example, the next 

window shows the properties of the layer “Runoff_1 [water column]”. 

 

To know more on how to customize the time series window (axis titles, series names 

and colors, etc.) and map images (color scale, horizontal scale, etc.) check the MOHID 

Studio User Guide. 

With this we finished the first exercise. In the next exercise we will create a new 

project from scratch. Please close MOHID Studio. 
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4 Exercise 2 - Simulating rainfall runoff event 

4.1 Introduction 

This section will show how to create a MOHID Land project to simulate a rainfall runoff 

event. We will simulate the same area as in the previous example, but rather than 

using a prepared project, we will go through all steps required to set up the model. The 

area we will simulate is the same as in the previous example. 

4.2 Preparation 

For Exercise 2, please download the files “Estuary.xy”, “TrancaoPoints.xyz” and 

RiverCenterLines.xml and store them in C:\MOHID Land Quick Start Guide\Temp (or 

any other directory created in 3.2) 

� http://www.actionmodulers.com/Downloads/Estuary.xy 

� http://www.actionmodulers.com/Downloads/TrancaoPoints.xyz 

� http://www.actionmodulers.com/Downloads/RiverCenterLines.xml 

Now your “temp” directory should look like shown in the next figure. 

 

4.3 Step 1 – Creating a new Workspace, Solution and Domain 

First we will create a new workspace for our project. Start MOHID Studio and select 

Home -> Workspace -> Open from the main menu. The Workspace Manager Window 

appears. Select “Start with an empty Workspace” and provide the name “My First 

Workspace”. Your window should look like the one shown in Figure 4.1. 
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Figure 4.1: Workspace Manager Window – Creating a new Workspace 

Click on “OK” to close the window. 

Create a new solution by selecting Project -> Solution -> New from the main menu. 

 

The Create or Open Solution Window appears. Select “Create a new Solution” and 

provide the name “My First Solution”. Your window should look like the one shown in 

Figure 4.2.2 

                                                      

2 Even in a first approach it seems that a “Workspace” and a “Solution” are the same, they aren’t. You 

will later understand the differences.  
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Figure 4.2: Create or Open a Solution – Creating a new Solution 

Click OK to close the window. You should now see the solution in the Explorer Window 

-> Project Tree as shown in the next figure. 

 

Figure 4.3: Explorer Window after creating a solution 

Now we select the solution in the Project Tree and select Project -> Domain -> New 

from the main menu. The Domain window appears. As “Domain Name” use “Trancao 

Watershed” and for the root directory select the following directory: 

C:\MOHID Land Quick Start Guide\Projects\Trancao Watershed 

You can use the button to browse for the Root Directory. Here you can browse for 

the directory where you like to store the files associated with the domain. In this 

example we created a subdirectory “Trancao Watershed” in the directory created in 

3.2. 

Also change the “Numerical Model” to “MOHID Land”. 

Your window should now look like the one shown in Figure 4.4. 
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Figure 4.4: MOHID Studio create new domain 

Leave all the other fields empty and press OK to close the window. 

Now we have created the basic structure of the project (solution + domain). Your 

Explorer Window should look like shown in the next figure. 

 

Figure 4.5: Explorer Window after creating workspace, solution and domain 

More information on how to manage solutions and domains can be found in “MOHID 

Studio User Guide” in chapter 3. 

4.4 Step 2 – Generate the Topography 

4.4.1 Introduction 

Now we will generate a topography file. This file defines the horizontal domain 

(computational grid and height values for each grid cell) and is the basic and most 

essential information need to run any MOHID Land simulation.  
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To create a topography file, the following is needed: 

• Digital terrain data in point format (XYZ) 

• A polygon defining the areas where the model will not calculate any values 

(water points). 

• The computational grid for the model. 

The digital terrain data can be obtained from many sources (e.g. ETOPO, SRMT, local 

data provider), but it must be formatted into MOHID’s XYZ format. More information 

about MOHID’s XYZ format can be found here: 

http://www.mohid.com/wiki/index.php?title=XYZ_Points 

For this exercise we downloaded already, during the preparation process, the file 

“TrancaoPoints.xyz”. You can open this file with any text editor to check the format. 

The polygon defining the areas where the model will not calculate any values can be 

provided in MOHID’s XY format, MOHID Studio’s XML format or as ESRI Shapefile. For 

this exercise we downloaded already, during the preparation process, the file 

“Estuary.xy”. You can open this file with any text editor to check the format. More 

information about this XY format here: 

http://www.mohid.com/wiki/index.php?title=Polygon 

The computational grid will be constructed with a specific tool found inside MOHID 

Studio. 

4.4.2 Importing the base data into the simulation 

Even not strictly required, we will copy the two previously downloaded files into the 

directory structure of the solution we just created. Expand the “Project Tree” and 

select the folder “Digital Terrain”. After selecting, right click it and choose “Import 

File…”, as shown in the next figure. 
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Figure 4.6: Importing the base data 

Browse to the directory (C:\ MOHID Land Quick Start Guide\Temp) where you stored 

the files “TrancaoPoints.xyz”, “Estuary.xy” and “RiverCenterLines.xml”, select the three 

files and click Open. You should now see these files listed under Modules -> Data Files. 

 

Figure 4.7: Files after importing 

4.4.3 Adding the base data to the map 

Under the Modules -> Data Files, select the file “TrancaoPoints.xyz” and select “Add to 

Map” from the context menu (Figure 4.8). 

 

Figure 4.8: Adding the base data to the map 1/2 

On the dialog which appears, just press OK to continue. 
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Figure 4.9: Adding the base data to the map 2/2 

Repeat the steps above for the file “Estuary.xy” and the file “CenterRiverLines.xml” 

Now, when switching to the “Map” you should see an image similar to the one shown 

in the next figure. 

 

Figure 4.10: Map with base data 

4.4.4 Generate the computational grid 

Open the Tool Box and double click on Grid -> Constant Spaced Grid. This will open the 

“Constant Spaced Grid Tool” docked on the right of the main area. Your window 

should look like the one shown in the next figure. 
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Figure 4.11: Create Constant Spaced Grid tool 

We will create a constant spaced horizontal grid with the parameters indicated in the 

next table. 

Parameter Value Description 

Coordinate Type 
Geographic Coordinates (the 

default) 

Type of the coordinates to use. Options are 

geographic, UTM and metric (local) coordinates. 

Origin X -9.275 X coordinate of the lower left corner. 

Origin Y 38.755 Y coordinate of the lower left corner. 

Columns 205 Nº of columns of the grid 

Rows 232 Nº of rows of the grid 

dX 0.001 Size of the grid cells along the X axis. Given in units of 
the coordinate system (in this case º). 

dY 0.001 Size of the grid cells along the Y axis. Given in units of 
the coordinate system (in this case º). 

Angle 0.0 Rotation of the grid. 

After filling this options, your window should look like shown in the next figure. 
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Figure 4.12: Create Constant Spaced Grid tool - 2 

Press the save button ( ) in the lower right corner of the tool window and to save 

the grid file with the name “TrancaoGrid.grd” in the directory C:\MOHID Land Quick 

Start Guide\Projects\Trancao Watershed\General Data\Digital Terrain. 

 

Figure 4.13: Selecting the destination of the grid file 

When the tool closes, the grid remains loaded in the Map Window. 



M O H I D  L a n d  Q u i c k  S t a r t  

 
A c t i o n  M o d u l e r s  -  w w w . a c t i o n m o d u l e r s . c o m  3 5  

 

4.4.5 Generate the digital terrain 

The base data for any MOHID Land model is the digital terrain (or topography), which 

is provided in form of a Grid Data file. More information about MOHID’s Grid Data 

format can be found here: 

http://www.mohid.com/wiki/index.php?title=Grid_Data 

MOHID Studio contains several tools to create and manipulate grid data files.  

Now, to create the topography we will need three data sets: 

• XYZ points (TrancaoPoints.xyz - already loaded) 

• Definition of the non-compute areas (Estuary.xy - already loaded) 

• The computational grid (TrancaoGrid – created in the previous step) 

To create the grid data we will use the “Grid Data” -> “Construct from Points” tool. 

Double click the tool to open it, as shown in the next figure: 

 

Figure 4.14: The Construct Grid Data Tool 

We will now construct the topography with the following options indicated in the 

following table. 
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Parameter Value Description 

Grid Trancao Grid The grid which is to be used to create the grid data. 

XYZ Points TrancaoPoints The point dataset(s) which are to be used to fill the 

grid. In this example we only have one, but you can 
use multiple XYZ files. 

Polygons Estuary (check it!) The polygon(s) which define non compute areas 
(water bodies in the case of MOHID Land). The model 

will not compute any values in the cell covered by 

these polygons. 

XYZ Offset 10% Offset from the grid, in percentage, of the maximum 

distance from the “XYZ Points” are considered when 
using interpolation algorithms. 

Fill Value -99.0 The value to be attributed in non-compute areas. You 
should not change this value unless you have a 

specific reason for. 

XYZ in NCA Leave uncheck If you want to consider a specific height in the non-

compute areas for the interpolation process near the 

land-water interface. 

Interpolation Triangulation The interpolation method you want to use. If the 

density of points is smaller than the number of grid 
cell (not every cell contains a XYZ Point), then this 

option is the recommended one. 

Grid Data C:\MOHID Land Quick Start 

Guide\Projects\Trancao 

Watershed\General 

Data\Digital Terrain\ 
TrancaoTopography_v01.dat 

The name of the file which will be created. It’s 

recommended to place this file inside the folder 
General Data\Digital Terrain of your project. 

After filling all data, choose the process button ( ) to generate the topography. This 

process might take a couple of minutes and it finished with a status message. 

 

Figure 4.15: Status message of the Construct Grid Data Tool 

Close the status message and the tool window (using the x). Your main window should 

now like the one in the following figure. 
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Figure 4.16: Window after creation of the topography 

4.4.6 Smooth the digital terrain 

After creating the topography, we should check it for noise, which sometimes appears 

especially in flat flood plains and/or when the source point data came from satellite 

imagery (e.g. SRTM). This step is optional and the user should check first if the digital 

terrain has “noise” and use this tool only if it exists and where it exists (the user may 

define to “denoise” all topography cells or only in a defined area). 

We now change the color range of the topography to values between 0 and 20 to 

check the downstream part (flat flood plain) where the “noise” exist. Under Map, 

select the layer “TrancaoTopography_01” and double click it to access the layers’ 

properties. In this window change the values “Min Value” to 0, “Max Value” to 20 and 

uncheck the “Above Max” option, as shown next. 
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Press close to return to the map window. We now see, in the highlighted area in the 

next figure that the topography has a lot of noise.  

 

We will now use the tool “Smooth Grid Data” to reduce this “noise”. From the tool box 

select “Grid Data” -> “Smooth”, as shown in the next figure. 



M O H I D  L a n d  Q u i c k  S t a r t  

 
A c t i o n  M o d u l e r s  -  w w w . a c t i o n m o d u l e r s . c o m  3 9  

 

 

Under the available option we select as original grid data the “Topography_v01” and as 

new grid data “TrancaoTopography_v01_Smoothed.dat”. These options are set by 

default. Under “2. Options” we check “Denoise Algorithm” and leave all other option 

with their default values. We press now the button to generate a new grid data. 

Once done, close the tool. The new grid data is available in the list of layers. If we now 

select this layer in the layers’ list and double click it, we can set its properties has we 

have done previously (“Min Value” to 0, “Max Value” to 20 and uncheck the “Above 

Max” option) to with the original layer. You should now see the grid data with less 

noise in the “critical area”.  
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4.4.7 River “Burn In” the digital terrain 

In order to further improve digital terrain, an optional step of “River Burn In” should be 

used. This process allows you to modify the grid data and “burn in” rivers. The user 

should check the model river network first (created in next steps) without “burn in” 

against actual river network and only use this tool if required and in the river stretches 

where automatically generated network locations is significant different from reality. 

This step is not always required, but in our sample the watershed has some narrow 

valleys and a lot of flat flood plains where elevation data resolution is coarse to 

describe these features and previous river delineation showed that some river 

stretches would move aside from real position with automatic delineation without the 

“burn in”. So in this case the step of “burn in” is recommended.  

First we will arrange our layers in the map. Turn the layers “TrancaoPoints”, “Estuary”, 

“TrancaoGrid” and “TrancaoTopography_v01” off, by unchecking them in the Layer List 

window. Also move the layer “River Center Lines” to the top by using the context 

menu (right mouse button) to choose “Move Up”. Once done, you layer list should 

look like the one shown in the next figure. 

 

Now double click the layer “TrancaoTopography_v01_Smoothed” and reset the 

properties in a way that all values are visible. Use the options which are indicated in 

the next figure. 
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You window now should look like the one showing in the next figure. 

 

We now select “Grid Data” -> “River Burn In” from the tool box.  
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In the tool, under “Lines (River Center)”, check the layer “RiverCenterLines” and under 

output select as new output file for a file “TrancaoTopography_v02.dat” (in the same 

directory where are already the other files). Press the process button to perform the 

“Burn In” operation. Once done, the new topography is added as new layer. You can 

now close the tool. 

4.4.8 Remove depressions from the digital terrain 

In the case you want to run MOHID Land with the module to simulate rivers explicitly, 

the topography needs to be free of depressions. We will now use the tool “MOHID 

Land” -> “Remove Depression” from the toolbox. 
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Under the available option we select as original grid data the “Topography_v02” and as 

new grid data “TrancaoTopography_v02_ND.dat”. These options are set by default and 

“ND” stands for “No Depression” 

This tool works in two steps. First we need to find all depressions, by analyzing the 

DTM. This is done by using the process button ( ) in the “Select DTM” box. 

 

Once this process is finished all depressions in the topography are highlighted in the 

map window and shown in the list of layers, as shown in the following figure. 
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This tool has many options to remove the depressions. We will use the default options 

and remove all depression by iterations. This is done by using the second process 

button. 

 

Once concluded, all depressions of the topography disappear. You can now press the 

save button the save the topography and exit the tool. 

NOTE: Some time the process of depression removal can take a long time. You should 

carefully check what happens and probably spend more time on the topography 

smoothing / river burn in options.  

The process of preparing the topography is finished. 
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4.5 Step 3 – Associate the domain with the topography 

In step 1 we created a new workspace, solution and a domain. In step 2 we created the 

topography. We will now associate the domain with the topography (this is needed 

because you may have more than one topography). To do so, please switch back to the 

Explorer Window, select the domain “Trancao Watershed”, right click and choose 

“Properties”. 

 

Figure 4.17: Accessing the properties of the domain 

A window with the properties of the domain will show. Under “Digital Terrain”, browse 

for the final, depression free, topography you created earlier C:\MOHID Land Quick 

Start Guide\Projects\Trancao Watershed\General Data\Digital Terrain\ 

TrancaoTopography_v02_ND.dat) as shown in the next figure. 

 

Figure 4.18: Associating the topography to the domain. 

Now press OK to close the window. 
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4.6 Step 4 – Delineation of the watershed 

MOHID Land is prepared to run for a single watershed or for multiple watersheds at 

the same time. In the current case we will cover the option to run a single watershed, 

which requires that the watershed is delineated. 

Watershed delineation requires that the topography is free of depressions, that’s why 

we created in the previous step the layer ““TrancaoTopography_v02_ND.dat”. We will 

now delineate the watershed using the “MOHID Land” -> “Delineate Watershed” tool. 

 

As the previous tool, this also requires generally two steps. Since we don’t know where 

exactly the river passes, we will have to run the tool once to generate all rivers, select 

then an outlet and rerun the tool. 

So, as a first step we select the digital terrain we want to process, in this case 

TrancaoTopography_v02_ND (should be selected by default). 

 

Leaving all other options with the default parameters we go straight to point “4. 

Process” and run the basin delineator tool by pressing the process button. Once done, 
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the status of the tool is display in the message box and a new layer with the drainage 

network is added to the map. 

 

We now have to select the outlet and rerun the tool. This is done by the option “2. 

Delineation Option”. We check the option “Delineate Basin” and, for this example, 

specify “Outlet X” = -9.0925 and “Outlet Y” = 38.7965, as shown in the next figure. 

Once done a marker appears on the map, indicating the position of the outlet. Usually 

this is done by selecting the location with the mouse, by using the  button, on top 

of the drainage network built in the previous step (so that we choose an outlet in an 

existing model reach). 

 

NOTE: The outlet location must be in a cell where the drainage network passes and 

cannot lie on the border of the watershed. If you look closer to the figure above, you 

will notice that there is one cell between the choose location and the border (grey 

area). 
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Once these options are set, press again the process button under 4. Once finished one 

or more warnings will appear asking you to replace the existing layers. Press “Yes” to 

continue and close the tool. 

 

Your window will now look like the one shown in the following figure. 

 

Now we finished the delineation of the watershed. 

NOTE: Later on we will need to now the maximum Strahler order of the network. If we 

select the “Drainage Network” layer and use the query tool ( ), we can query 

information about a specific layer. Near the outlet the maximum Strahler order is 4. 

4.7 Step 5 – Define cross sections of the drainage network 

In order to calculate the propagation of the flow, MOHID Land’s river module requires 

that the drainage network has cross sections defined for each node. This can be done 

using the tool “MOHID Land” -> “Default Cross Sections”. 
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This tool allows to define default cross sections for all river reaches, using one of the 

two methods: (i) cross sections in function of the Strahler order or (ii) cross sections in 

function of drained area. In this example we will use the first one.  

For each Strahler order we have to define a cross section and use the add button to 

add them to the list of cross sections, using “2. Default Cross Sections” 

 

We will use the following values: 

Order Type Top Width Bottom Width Height 

1 Trapezoidal 10m 5m 5m 

2 Trapezoidal 20m 10m 5m 

3 Trapezoidal 30.0 15m 5m 

4 Trapezoidal 50m 25m 10m 
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After adding these values, the box “2. Default Cross Sections” should look like shown in 

the following figure: 

 

Once done click the save button under “4. Save Network”.  

 

The tool will close and all nodes have a cross section defined. 

4.8 Step 6 – Create a new simulation 

So far we created the basic input files which are need to run any MOHID Land model. 

We will now create a simulation and fill the compute options for all modules. 

In the Explorer Window select again the domain “Trancao Watershed” right click and 

select “Insert Simulation”. A window with the properties of a new simulation will 

appear. In the window you have to provide a name of the simulation, a small 

description and choose which modules you want to activate. 

We will remove the modules “Geometry” and “PorousMedia” with the  button and 

they will move from the “Modules in Simulation” box to the “Available Modules” box 

as shown in Figure 4.19. 
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Figure 4.19: Creating a new simulation 

Press OK to close the window. A new simulation is created and will appear in the 

project tree. When you select this simulation, the module data files will appear. 

 

Figure 4.20: Explorer Window after creating a new simulation 

4.9 Step 7 – Define the simulation properties 

Selecting the simulation you just created shows that it has several input files listed in 

the “Modules” section under “Data Files”. In these files we have to specify the options 

for each module. Main files have already default options and here we will only change 

the files which require modification. 
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4.9.1 Step 6.1 – Time Options – Model_1.dat 

The simulation start, end and time step is provided in the file Model_X.dat where is X 

is the simulation number (e.g. Model_1.dat). Under “Modules” double click the file 

“Model_1.dat”, which will open in the file editor. 

 

Figure 4.21: Model_1.dat in the File Editor 

Change the values to the following options (You should avoid using TABs). 

Parameter Value Description 

START 
2015 1 1 0 0 0 Start instant of the simulation. Values are year, 

month, day, hour minute and second. 

END 2015 1 2 0 0 0 End instant of the simulation. Values are year, 

month, day, hour minute and second. 

DT 10.0 (Initial) Time step of the model, in seconds. 

VARIABLEDT 1 If a variable DT is to be used. 0 to switch off, 1 to 

switch on. For MOHID Land always use 1. 

MAXDT 600.0 Maximum DT if variable time step is used. 

GMTREFERENCE 0 Has the same as the time reference as in the tidal 
tool. If running the model in a place other than in 

GTM + 0 than need to edit accordingly (positive to 
east and negative to west). 

DT_PREDICTION_INTERVAL 15.0 Interval, in seconds, when progress notifications are 
displayed. 

 

After editing the file and changing the values as shown in the table above, save and 

close the file by pressing close button. 
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Figure 4.22: Saving and closing a file in the file editor 

4.9.2 Step 4.3 – Watershed delineation – BasinGeometry_1.dat 

The data file “BasinGeometry_1” must contain again the information about the outlet 

and the threshold area, which must be consistent with the options used during the 

basin delineation process. Open the file “Basin_Geometry_1.dat”. Now navigate in the 

Explorer to “Trancao Watershed -> General Data -> Digital Terrain” you will find a file 

called “Basin Geometry Info”. Open it also by a double click. 

 

Copy the four marker lines (TRESHOLD_AREA, DELINEATE_BASIN, OUTLET_I and 

OUTLET_J) and switch back to the file “Basin_Geometry_1.dat” and replace these four 

lines. 

 

Now close and save the file BasinGeometry_1.dat and close the file 

BasinGeometryInfo.dat. 

Under the Project Tree select again the simulation “Sim #1”. 
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4.9.3 Step 4.4 – Precipitation – Atmosphere_1.dat 

The options related with the atmosphere module are provided in the file 

“Atmosphere_1.dat”.  In this example we will create a constant precipitation of 

3mm/h. 

When you open the file “Atmosphere_1.dat” MOHID Studio will generate a default file, 

containing a commented example. 

 

We will uncomment the block “<beginproperty>” “<endproperty>” by removing the 

“!” from the beginning of the lines. You can do this line by line or by selecting all lines 

and you the button  at the top of the file editor. Inside the block we will change all 

lines so only lines indicated in the following table appear (remove all other lines). 

Parameter Value Description 

NAME Precipitation Name of the property to simulate. The names in MOHID are 
case sensitive. 

UNITS mm/hour Units in which the property is given. Note that in most cases 
MOHID does NOT allow conversion of unit and all values 

must be specified in SI units. Precipitation is an exception, 
allowed values are mm and mm/hour. 

DESCRIPTION Constant rain A description of the property. 

DEFAULTVALUE 3 Value of the constant rain, in mm/h 
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REMAIN_CONSTANT 1 If the imposed value remains constant over time. 1- Yes, 0 – 

No 

USE_ORIGINAL_VALUES 1 If the values are to be interpolated in time (1 – no 

interpolation) 

TIME_SERIE 1 If to produce time series output of this property. 1- Yes, 0 – 

No 

OUTPUT_HDF 1 If to produce map output of this property. 1- Yes, 0 – No 

Once done, your file should look like the one shown below. 

 

Now save and close the file. 

4.9.4 Step 4.5 – General basin options – Basin_1.dat 

General option about the processes to simulate are defined in the file “Basin_1.dat”.  

Double click the file to open it in the File Editor. 

Check the following options. 

Parameter Value Description 

ATMOSPHERE 1 If to use the atmosphere module. 1- Yes, 0 – No. 

EVAPOTRANSPIRATION 0 If to calculate evapotranspiration. 1- Yes, 0 – No. 

POROUS_MEDIA 0 If the porous media module is to be used. 1- Yes, 0 – 
No. 

RUN_OFF 1 If the surface runoff module is to be used. 1- Yes, 0 – 
No. 

DRAINAGE_NET               1 If the drainage network module is to be used. 1- Yes, 

0 – No. 

SCSCN_RUNOFF_MODEL               1 Calculate Infiltration using the Curve Number 

Method. 1- Yes, 0 – No. 
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Leave all the other options unchanged. Save and close the file. 

4.9.5 Step 4.6 – River Flow – Drainage Network_1.dat 

MOHID Studio created a default template file with a set of options for the drainage 

network. For this first example you can leave the default options unchanged. 

4.9.6 Step 4.6 – Overland Flow – Runoff_1.dat 

MOHID Studio created a default template file with a set of options for the surface 

runoff routing. For this first example you can leave the default options unchanged. 

4.9.7 Time series output 

By default time series output is switched on in most modules, so we need to create a 

file which contains the locations of the places where time series are to be written. This 

has to be done for time series of specific grid locations (e.g. infiltration rate, 

precipitation rate) and for specific nodes of the drainage network (e.g. flow, channel 

water depth). 

The link to the file which defines the place where time series are to be written is given 

by the keyword “TIME_SERIE_LOCATION”. 

For grid time series this file can be create using the tool “Grid Location”. 
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With this tool use the “Add Points” button ( ) to add new places. Select one place 

somewhere in the center of the watershed. Then also select the “Save also as XML 

Geometry” option. Your screen should now look like: 

Now save all information, by pressing the “Save Button” ( ), using the following 

path: 

C:\MOHID Land Quick Start Guide\Projects\Trancao Watershed\General Data\TimeSeriesLocation.dat 

After saving the tool window will close and the layer with the marks will be removed. 
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For node time series this file can be create using the tool “Node Location”. 

 

Using again the “Add Points” button ( ), select a place over the drainage network. 

Then also select the “Save also as XML Geometry” option. Your screen should now look 

like: 

 

Now save all information, by pressing the “Save Button” ( ), using the following 

path: 
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C:\MOHID Land Quick Start Guide\Projects\Trancao Watershed\General 

Data\NodeTimeSeriesLocation.dat 

4.10 Step 8 – Run the simulation and explore results 

Everything now is prepared to run the simulation. In the Explorer Window select the 

simulation Sim #1 and then select the option “Project” -> “Run Now” from the main 

menu (further details have been described earlier). In the message box which appears, 

click “Yes” to start the run. It will take some minutes to complete the simulation. 

When the model finishes, a message box will pop, asking if you would like to see the 

model results. Click “Yes” and a window like the one shown in the next figure will be 

shown. 

 

After any simulation, you should scroll down to the end of the window, checking the 

final status message, as shown in the next figure. 
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In this case the model log tells us that the model did finish successfully. 

You can know explore the results by adding layers to the map or by creating time 

series graphs, as described in section 3.6. 



M O H I D  L a n d  Q u i c k  S t a r t  

 
A c t i o n  M o d u l e r s  -  w w w . a c t i o n m o d u l e r s . c o m  6 1  

 

5 Exercise 3 – Exploring Additional Examples 

5.1 Introduction 

In Exercise 1 we downloaded a previously created model setup and imported it into 

MOHID Studio. The goal was to learn a little bit how MOHID Studio works. 

In Exercise 2 we created a new model setup from scratch using some basic data files. 

The goal of the second exercise was to learn the basic steps you need to setup a simple 

MOHID Land simulation. 

MOHID Land has hundreds of options, so sometimes it’s tricky to find the right option 

for all the data files. In this exercise, Exercise 3, we will show how to open existing 

online resources which you can use as guidance to setup you own model.  

5.2 Step 1 – Startup Page 

MOHID Studio’s Start-up page has on the right side a set of online resources, which 

ACTION MODULERS updates frequently. To access the start page, select Home -> Links 

-> Start. 
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This page is allows shown after start up but, by default, it closes after opening a work 

space. You can change this behaviour in the lower left corner of the Start-up page. 

We will now select a more advanced sample of the Trancão Watershed, which contains 

different types of simulations. 

5.3 Step 2 – Download and open advanced examples 

In the Startup Page check for the resource “Example Simulations in the Trancão 

Watershed, including hydrology, sediment transport and water quality”, as indicated in 

the figure below. 

 

Click on this line. A popup window will appear which asks for where to store this 

example.  

Create a directory in C:\MOHID Land Quick Start Guide\Projects called “Trancao 

Advanced” and press OK. 
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The download of the sample will start automatically. Once the download is completed 

(a message box informs you about this) your current workspace is closed and the 

download example is opened automatically. After expanding the project tree your 

window should now look like the one indicated next. 



M O H I D  L a n d  Q u i c k  S t a r t  

 
A c t i o n  M o d u l e r s  -  w w w . a c t i o n m o d u l e r s . c o m  6 4  

 

 

Inside this example you will find a set of simulations, showing different features of 

MOHID Land. We recommend that you run and explore these examples. 

The first simulation is the same which we already explored in Exercise 1. Please check 

the following observations. 

Name Objective Observations 

Sim #1 Simple watershed simulation 

considering an impermeable 
watershed.  

For demo purposes only. Be aware that impermeable 

watershed can generate huge floods, even for small 
rain events. 

Sim #2 Watershed using Curve 

Number method to calculate 
infiltration. Atmospheric 

properties from time series and 
evaporation switched on.  

Data files show how to implement Curve Number 

infiltration with MOHID Land. For real cases you 
should consider creating a Grid Data for real curve 

number values, changing the block 
“BeginCurveNumber> / “<EndCurveNumber>” inside 

the file Basin_2.dat. The tool Grid Data -> Construct 
from shape might be useful for this.   

Sim #3 Complete hydrological 
simulation, including also 

interaction between surface 

water, groundwater and return 
flow. 

Data files show how to implement some even more 
advanced features in MOHID Land. Module Porous 

Media and a vertical Geometry have been added. 

Infiltration is now calculated by module Porous 
Media, based on soil moisture. 

Sim #4 Same as previous with 
sediment transport in surface 

waters added, including 
generation of sediments due to 

rain splash. 

Sediment transport is characterized in the files 
Drainage Network and Runoff Properties. 

Sim #5 Same as previous with point 

discharges from WWTP and the 

Data files show how to activate the water quality 

module (WaterQuality_v5 and SedimentQaulity_v5) 
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full nutrient cycle (phosphorus 

and nitrogen) to simulate the 
transport and transformation 

of properties in surface and 
subsurface waters.  

and the transport in surface (Runoff Properties_v5 

and DrainageNetwork_v5) and subsurface waters 
(Porous Media Properties_v5) 

When setting up a MOHID Land model at your site, you can use these examples as 

guidance. Basic steps are: 

1. Create a new domain, including computational grid and topography, as shown 

in Exercise 2; 

2. Copy data files from the examples to the new created domain; 

3. Adopt the data files where needed. 

There are 2 features in MOHID Studio which you might find particularly interesting: the 

option to compare data files between simulations (Project -> Simulations -> Compare) 

and to copy data files from one Project/Simulation to another (Project -> Simulation -> 

Copy). 

 

Please check MOHID Studio’s User Guide for further information. 

6 Final Remarks  

This quick start-guide to implement MOHID Land intends to help first time users to 

quickly get the model running but may also be a starting point for every new 

implementation. The implementation of MOHID Land in these terms, with increasing 

complexity and processes added in cumulative way, gives user the sensibility to the 

major factors affecting circulation and water quality for each implementation site. 

Any difficulties or need for more developed information should be addressed in the 

MOHID channels mentioned at the start of this document. 

We appreciate all feed-back that you may give us on the implementation of MOHID 

Land projects with MOHID Studio so that this guide can improve with time. 


