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This document is the MOHID Studio Quick Start Guide for MOHID Water. It contains a 

tutorial on how to create a MOHID Water project with MOHID Studio.  

This document makes part of the MOHID Studio Documentation. 
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1 Preface 

1.1 Copyright 

This document refers to MOHID Studio, proprietary computer software which is 

protected by copyright. All rights are reserved. Copying or other reproduction of this 

document or related programs is prohibited without prior written consent of Action 

Modulers, Consulting & Technology (Action Modulers). 

MOHID Water Modelling System is proprietary software of the Instituto Superior 

Técnico (University of Lisbon). 

1.2 Warranty 

The warranty given by Action Modulers is limited as specified in your Software License 

Agreement. Please note that numerical modeling software programs are very complex 

systems and may not be free of errors, so you are advised to validate your work. 

Action Modulers shall not be responsible for any damage arising out of the use of this 

document, MOHID Studio, MOHID Water Modelling System or any related programs or 

documents. 

1.3 Further Information 

For further information about MOHID Studio please contact: 

Action Modulers, Consulting & Technology, Ltd. 

Estrada Principal, nº 29 - Paz 

2640-583 Mafra, Portugal 

Tel.: +351 261 813 660 

Fax: +351 261 813 666 

E-mail: geral@actionmodulers.com 

Web: http://www.actionmodulers.com 
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2 Quick Start Tutorial for MOHID Water 

This “Quick Start Tutorial for MOHID Water” is intended to help first-time users 

creating their first projects, following a sample project, an implementation in the Tagus 

Estuary, near Lisbon, Portugal. 

It is suggested that you follow the tutorial, which progresses with increasing 

complexity, trying to replicate the provided sample project. After finished exploring all 

simulations with the samples, it is suggested that you revisit the tutorial applying the 

model examples to your own study site. 

The tutorial starts with a preconfigured sample project, which is downloaded from 

Action Modulers’ web site, so you can get used to MOHID Studio’s environment, 

including projects and simulation structure, graphical visualization, running the model. 

All these tasks can be performed without any previous knowledge about using MOHID 

Studio / MOHID Water.  

After the first play-around you are invited to independently create a simple project 

with 2D hydrodynamics forced with tide, generating the bathymetry and tide files, 

prepare the input files, run the model and explore results as previously.  

The tutorial then shows how to access more complete example covering full 3D 

simulation with river discharges and meteorology, sediment transport, point sources 

and nutrient transport and transformation (full water quality simulation), resulting in a 

quiet complete simulation that can be run with MOHID Water. 

For each step, the require options to configure the model are explained in detail.  

This is intended to be a step-by-step tutorial to implement in a straightforward way a 

MOHID Water project from simpler to complex simulations. Detailed description of the 

governing equations used by the model is not provided in this guide; neither a detailed 

description of the processes solved by the model is provided. For further information 

about these topics, you should explore the following MOHID related sources: 

Action Modulers website – http://www.actionmodulers.com 
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MOHID website – http://www.mohid.com/ 

MOHID wiki – http://wiki.mohid.com/wiki 

MOHID forum – http://www.mohid.com/forum/ 

MOHID code repository – http://mohid.codeplex.com/ 

It is assumed that you have installed already MOHID Studio (following MOHID Studio’s 

Installation Guide) and that you understand the functioning of the different windows, 

environments and buttons (following MOHID Studio User Guide). 

This manual applies to MOHID Studio 2016 (version 3.0).  

In order to complete all steps in this document, you must have a Professional or an 

Evaluation License. 
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3 Exercise 1 - Explore a previously configured project 

3.1 Introduction 

The tutorial starts by providing a sample project so you can get familiarized to MOHID 

Studio. You will use a previously configured project and produce results with it.  

3.2 Preparation 

For Exercise 1, please prepare your PC the following steps: 

1. Create a directory C:\MOHID Water Quick Start Guide1 

2. Create a directory C:\ MOHID Water Quick Start Guide\Temp 

3. Create a directory C:\MOHID Water Quick Start Guide\Projects 

Download the demo project from the link below and store it in the “temp” directory 

created in 2.  

� http://www.actionmodulers.com/Downloads/TagusSample.zip 

Please do not “unzip” this file, since MOHID Studio is expecting a ZIP file. 

Now your directory should look like shown in the next figure. 

 

 

                                                      

1 You can alternatively create this structure on a different disk (e.g. D:\) 
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3.3 Start MOHID Studio and import the preconfigured 

example 

Start MOHID Studio by selecting Start -> Action Modulers -> MOHID Studio 2016. 

 

You can alternatively use the icon on your desktop. 

 

For this example, we have to create a new workspace. After MOHID Studio started, 

please select Home -> Workspace -> Open from MOHID Studio’s main menu. 
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MOHID Studio’s Workspace Manager Window appears which allows you to create a 

new work space. Choose “Start with an empty Workspace” and name it “MOHID Water 

Quick Start Guide”. 

 

Figure 3.1: MOHID Studio Workspace Manager 

Press ok to close the window. 

Now we will import the previously configured example. Please select Project -> 

Solution -> Manage. 
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MOHID Studio’s “Solution Management” window appears (Figure 3.2). 

 

Figure 3.2: MOHID Studio Solution Management 

In this window press the button “Import”, located on right. The window “Import 

MOHID Solutions” will appear. 

 

Figure 3.3: The Import MOHID Solution window 
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Select Solution Type “MOHID Studio” and under “Project File Name” browse for the 

file previously downloaded and stored in the “temp” directory (“C:\MOHID Water 

Quick Start Guide\Temp\TagusSample.zip”). 

The “Destination Directory” must be an empty directory. Please create a directory 

called “Tagus Sample” in “C:\MOHID Water Quick Start Guide\Projects”). You can to 

this after clicking the button, as shown in the next figure.  

 

Figure 3.4: Creating the destination directory 
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Once you are done, the “Import MOHID Solutions” window should look like the one 

shown next. 

 

Figure 3.5: MOHID Studio Import Solution 

Press the import button ( ) and wait until the import process is complete. 

 

Figure 3.6: Message informing that the import process has finished 

Close the message box and the “Import MOHID Solutions” window. In the “Solution 

Management Window” you should see now the imported solution, like shown next. 
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Figure 3.7: MOHID Studio Solution Management (after import) 

NOTE: If a solution with the same name of the solution to import already exists, the 

newly imported solution is automatically renamed (example: Tagus Sample_1). Close 

this window also. 

Now we have to open the solution we just imported and associate it to the current 

workspace, by selecting Project -> Solution -> Open. 

 

The “Create or Open Solution” window appears with the solution “Tagus Sample”, like 

shown in the next figure. 

NOTE: The “Create or Open Solution” window looks very similar to the “Create 

Workspace window”. The differences between workspaces and solutions are explained 

in the user manual. 
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Figure 3.8: The “Create or Open Solution” window 

In this window select “Open an existing solution” and select the “Tagus Sample”. Press 

“OK” to close the window. 

This action will open the “Tagus Sample” solution in “Explorer” tab. Press on the 

triangles ( ) to expand the tree view in the “Explorer”. You screen should now look 

like shown in the next figure. 
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Figure 3.9: MOHID Studio’s Explorer window after importing and opening the “Tagus Sample Project” 

Step 2 – Navigating in the project structure  

Like all MOHID Studio solutions, this solution is divided into the following items: 

the root element – the “Solution” 

one or more “Domains”, in this case the “Tagus Sample”. 

special folders for storing data common to all simulations 

simulations to run specific scenarios. 

In the middle of the explorer window you will find the “Modules”. By selecting any 

item in the “Project Tree”, the “Modules” in the middle of the explorer window will be 

updated. For example, if you select the simulation “Sim #1 2D Tide”, your window 

shows the data files associated with this simulation, as shown in the next figure. 
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Figure 3.10: MOHID Studio’s Explorer window – Data files 

NOTE: The “Modules” are divided into 3 areas: Data Files, HDF Files and Time Series 

Files. Details about these file types are explained in the user manual. 

The project management is one of the core features of MOHID Studio. Another feature 

is the internal GIS engine, which allows you to visualize all spatial data. Next we will 

show how to visualize the digital terrain of the Tagus Sample.  

3.4 Visualize the digital terrain of the Tagus Sample 

Adding layers to the GIS engine can be done directly from the “Explorer”. To add the 

digital terrain of the Tagus Sample, proceed in the following way: 

In the Project Tree select the folder “Digital Terrain” (1). This will fill the Data Files 

under “Modules”. Select the file “TagusBathymetry.dat” (2) and right click it. In the 

popup which appears select “Add to Map…” (3). Next screen shot shows these steps. 
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Figure 3.11: Selecting the bathymetry to be displayed in the map 

The window “Add Vector Layer” appears.  

 

Figure 3.12: The “Add Vector Layer” window. 

Just leave all default values as they are and press “OK”. 
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NOTE: If in this step appear a message complaining about the license, you don’t have a 

valid license to proceed (MOHID Studio Professional). We encourage you to request a 

temporary evaluation license. Check MOHID Studio’s Installation Guide for more 

information. 

Now switch to the “Map” tab to see the digital terrain in the map window. Your screen 

should look like shown in the next figure. 

 

Figure 3.13: MOHID Studio Map Window with Tagus Sample Bathymetry 

To add a background map go to “Map” -> “Background Layers” -> “Tiles” (Figure 3.14).  

 

Figure 3.14: Add a background layer 

A warning appears informing you that the coordinate system of the map has to be 

changed to “Web Mercator Projections” (Figure 3.15). Click “Yes” to continue. 
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Figure 3.15: Changing the coordinate system 

A window which lets you choose from a range of background layers will appear (Figure 

3.16). Choose “Bing – Aerial” and OK to add the layer to the map. 

 

Figure 3.16: Selecting the type of background layer 

Your main window now should look like the one in the next figure. 

 

Figure 3.17: MOHID Studio the Tagus bathymetry and a background layer 
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3.5 Running a simulation 

Now we will run a simulation of the sample project. Please switch back to the 

“Explorer” and in the “Project Tree” select the simulation “Sim #1 2D Tide” (1) and 

then select “Project” -> “Execute Models” -> “Run Now” (2). Figure 3.18 shows these 

two steps. 

 

Figure 3.18: Running the simulation Sim #1 

A window appears to confirm the execution of the model (Figure 3.19). Press “Yes” to 

continue. 

 

Figure 3.19: Confirm the execution of the simulation Sim #1 

The box window called “Model Controller” below the domains and simulations is filled 

showing the progress bar of the simulation (Figure 3.20). To check more details on the 

simulation status press “Output” button to be able to see what is the current 

simulation time, the current computer time and the expected computer time when the 

simulation will end. The “Cancel” button in the window allows you to abort the 

simulation at any time. 



M O H I D  W a t e r  Q u i c k  S t a r t  

 
A c t i o n  M o d u l e r s  -  w w w . a c t i o n m o d u l e r s . c o m  1 8  

 

 

Figure 3.20: MOHID Studio Model Controller 

At the end of the simulation a window notifies the user that the model has finished.  

 

Figure 3.21: MOHID Studio Model Finished 

To see the log file of the model run select “Yes”. A window with the log of the model 

run will appear. 
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Figure 3.22: Model run log file 

We recommend scrolling down this window until the end, so you can verify if the 

model did end successfully (Figure 3.23). 

 

Figure 3.23: Model run log file (end of file) 

3.6 Exploring the Results 

During the simulation the model output files are created. When selecting the 

simulation that just finished running (“Sim #1 2D Tide”), the “Modules” section in the 

middle pane is filled with “HDF Files” and “Time Series Files” result data (Figure 3.24).  
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Figure 3.24: Result files of the simulation Sim #1 

HDF files contain model results for the entire computational grid at different time 

instants of the simulation, similar to instantaneous snapshots of the study area. These 

results can be plotted as maps animated in time.  

Time series files contain results for predefined computational grid points with high 

output frequency. These results can be plotter as time series graphs.  

They way how these outputs can be configured will be explained later. More 

information on how to visualize results can be found in the “MOHID Studio User 

Guide”. 

We will start with creating a time series plot of the velocity modulus. For this we 

double click on the file “Channel.srh” in the “Time Series Files” list. A window appears 

with a list of available time series. We choose “[velocity modulus] [Tagus Sample] 

(Figure 3.25). 
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Figure 3.25: List of time series in the file “Channel.srh” 

After pressing ok MOHID Studio creates a new XY Graph window with a plot of the 

selected series. Your screen should look like the one in the next figure. 

 

Figure 3.26: MOHID Studio time series of velocity modulus (Sim # 1) 
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Now we will add the velocity of the entire domain as animated layer to the map 

window. 

First we switch back to the “Explorer Tab” and select the simulation “Sim #1 2D Tide” 

in the “Project Tree”. Then we double click on the file “Hydrodynamic_1.hdf5” in the 

HDF Files list. These steps are shown in the next figure. 

 

Figure 3.27: Displaying the velocity modulus as animated layer – step 1 

A window will appear which allows you to configure a set of options of what to display. 

Just leave all options unchanged (velocity modulus is the default property to display - 

Figure 3.28). 



M O H I D  W a t e r  Q u i c k  S t a r t  

 
A c t i o n  M o d u l e r s  -  w w w . a c t i o n m o d u l e r s . c o m  2 3  

 

 

Figure 3.28: Displaying the velocity modulus as animated layer – step 2 

Now you have to switch to the “Map” tab. Your screen should look like the one shown 

in the next figure. 

 

 Figure 3.29: Displaying the velocity modulus as animated layer – step 3 
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You can now use the “Date & Time” controller, located in the lower left corner, to step 

forward and backward in time (Figure 3.30) 

 

Figure 3.30: Displaying the velocity modulus as animated layer – step 4 

Now we switch back to the “Explorer Tab” and select the simulation “Sim #1 2D Tide” 

in the “Project Tree”. Then we select (this time NO double click) file 

“Hydrodynamic_1.hdf5” in the HDF Files list and use the small icon with the arrows in 

the upper right corner of this list. These steps are shown in the next figure. 
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Again a window will appear which allows you to configure a set of options of what to 

display. Just leave all options unchanged (velocity is the default property to display) 

and press OK. Switch to the Map TAB.  

Using again the timer to step forward in time, you can now see the velocity 

represented as colors and as arrows, as shown in the next figure. 

 

There are many ways to customize how these layers are displayed. You can access the 

properties of the current selected layer by pressing “F4”. For example, the next 

window shows the properties of the layer “Hydrodynamic_1 [velocity modulus]”. 
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To know more on how to customize the time series window (axis titles, series names 

and colors, etc.) and map images (color scale, horizontal scale, etc.) check the MOHID 

Studio User Guide. 

With this we finished the first exercise. In the next exercise we will create a new 

project from scratch. 

Please close MOHID Studio. 
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4 Exercise 2 - Simulating 2D Hydrodynamics forced 

with tide 

4.1 Introduction 

This section will show how to create a MOHID Water project to simulate 2D 

hydrodynamics. We will simulate the same area as in the previous example, but rather 

than using a prepared project, we will go through all steps required to set up the 

model. The area we will simulate is the same as in the previous example. 

4.2 Preparation 

For Exercise 2, please download the files “LandArea.xy” and 

“TagusBathymetryPoints.xyz” and store them in C:\MOHID Water Quick Start 

Guide\Temp (or any other directory created in 3.2) 

� http://www.actionmodulers.com/Downloads/LandAreaPolygon.xy 

� http://www.actionmodulers.com/Downloads/TagusBathymetryPoints.xyz 

Now your “temp” directory should look like shown in the next figure. 

 

Download the global tidal file (~518Mb) from here: 

ftp://ftp.legos.obs-mip.fr/pub/soa/maree/tide_model/global_solution/fes2004/tide/tide.fes2004.nc 

Store this file under C:\MOHID Water Quick Start Guide. 
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4.3 Step 1 – Creating a new Workspace, Solution and Domain 

First we will create a new workspace for our project. Start MOHID Studio and select 

Home -> Workspace -> Open from the main menu. The Workspace Manager Window 

appears. Select “Start with an empty Workspace” and provide the name “My First 

Workspace”. Your window should look like the one shown in Figure 4.1. 

 

Figure 4.1: Workspace Manager Window – Creating a new Workspace 

Click on “OK” to close the window. 

Create a new solution by selecting Project -> Solution -> New from the main menu. 
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The Create or Open Solution Window appears. Select “Create a new Solution” and 

provide the name “My First Solution”. Your window should look like the one shown in 

Figure 4.2.2 

 

Figure 4.2: Create or Open a Solution – Creating a new Solution 

Click OK to close the window. You should now see the solution in the Explorer Window 

-> Project Tree as shown in the next figure. 

 

Figure 4.3: Explorer Window after creating a solution 

                                                      

2 Even in a first approach it seems that a “Workspace” and a “Solution” are the same, they aren’t. You 

will later understand the differences.  
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Now we select the solution in the Project Tree and select Project -> Domain -> New 

from the main menu. The Domain window appears. As “Domain Name” use “Tagus 

2D” and for the root directory select the following directory: 

C:\MOHID Water Quick Start Guide\Projects\Tagus 2D 

You can use the button to browse for the Root Directory. Here you can browse for 

the directory where you like to store the files associated with the domain. In this 

example we created a subdirectory “Tagus 2D” in the directory created in 3.2 

Your window should now look like the one shown in Figure 4.4. 

 

Figure 4.4: MOHID Studio create new domain 

Leave all the other fields empty and press OK to close the window. 

Now we have created the basic structure to create the actual files we need to run 

MOHID. Your Explorer Window should look like shown in the next figure. 
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Figure 4.5: Explorer Window after creating workspace, solution and domain 

More information on how to manage solutions and domains can be found in “MOHID 

Studio User Guide” in chapter 3. 

4.4 Step 2 – Generate the Bathymetry 

4.4.1 Introduction 

Now we will generate a bathymetry file. This file defines the horizontal domain 

(computational grid and bathymetry values for each grid cell) and is the basic and most 

essential information need to run any MOHID Water simulation.  

To create a bathymetry file, the following is needed: 

• Digital terrain data in point format (XYZ) 

• A polygon defining the areas where the model will not calculate any values 

(land points). 

• The computational grid for the model. 

The digital terrain data can be obtained from many sources (e.g. ETOPO, local data 

provider), but it must be formatted into MOHID’s XYZ format. More information about 

MOHID’s XYZ format can be found here: 

http://www.mohid.com/wiki/index.php?title=XYZ_Points 
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For this exercise we downloaded already, during the preparation process, the file 

“TagusBathymetryPoints.xyz”. You can open this file with any text editor to check the 

format. 

The polygon defining the areas where the model will not calculate any values can be 

provided in MOHID’s XY format, MOHID Studio’s XML format or as ESRI Shapefile. For 

this exercise we downloaded already, during the preparation process, the file 

“LandAreaPolygon.xy”. You can open this file with any text editor to check the format. 

More information about this XY format here: 

http://www.mohid.com/wiki/index.php?title=Polygon 

The computational grid will be constructed with a specific tool found inside MOHID 

Studio. 

4.4.2 Importing the base data into the simulation 

Even not strictly required, we will copy the two previously downloaded files into the 

directory structure of the solution we just created. Expand the “Project Tree” and 

select the folder “Digital Terrain”. After selecting, right click it and choose “Import 

File…”, as shown in the next figure. 

 

Figure 4.6: Importing the base data 

Browse to the directory (C:\ MOHID Water Quick Start Guide\Temp) where you stored 

the files “TagusBathymetryPoints.xyz” and “LandAreaPolygon.xy”, select the two files 

and click Open. You should now see these files listed under Modules -> Data Files. 
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Figure 4.7: Files after importing 

4.4.3 Adding the base data to the map 

Under the Modules -> Data Files, select the file “TagusBathymetryPoints.xyz” and 

select “Add to Map” from the context menu (Figure 4.8). 

 

Figure 4.8: Adding the base data to the map 1/2 

On the dialog which appears, just press OK to continue. 

 

Figure 4.9: Adding the base data to the map 2/2 

Repeat the steps above for the file “LandAreaPolygon.xy”. 
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Now, when switching to the “Map” you should see an image similar to the one shown 

in the next figure. 

 

Figure 4.10: Map with base data 

4.4.4 Generate the computational grid 

The Tagus Sample (from Exercise 1) was built with a grid of variable resolution to make 

it more suited to describe the details of the Tagus Estuary and at the same time save 

computational time. To simplify the grid generation, in this exercise we will use a 

constant spaced grid.  

Open the Tool Box and double click on Grid -> Constant Spaced Grid. This will open the 

“Constant Spaced Grid Tool” docked on the right of the main area. Your window 

should look like the one shown in the next figure. 
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Figure 4.11: Create Constant Spaced Grid tool 

We will create a constant spaced horizontal grid with the parameters indicated in the 

next table. 

Parameter Value Description 

Coordinate Type 
Geographic Coordinates (the 

default) 

Type of the coordinates to use. Options are 

geographic, UTM and metric (local) coordinates. 

Origin X -9.57 X coordinate of the lower left corner. 

Origin Y 38.54 Y coordinate of the lower left corner. 

Columns 230 Nº of columns of the grid 

Rows 180 Nº of rows of the grid 

dX 0.003 Size of the grid cells along the X axis. Given in units of 

the coordinate system (in this case º). 

dY 0.003 Size of the grid cells along the Y axis. Given in units of 

the coordinate system (in this case º). 

Angle 0.0 Rotation of the grid. 

After filling this options, your window should look like shown in the next figure. 
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Figure 4.12: Create Constant Spaced Grid tool - 2 

Press the save button ( ) in the lower right corner of the tool window and to save 

the grid file with the name “TagusGrid.grd” in the directory C:\MOHID Water Quick 

Start Guide\Projects\Tagus 2D\General Data\Digital Terrain. 

 

Figure 4.13: Selecting the destination of the grid file 

When the tool closes, the grid remains loaded in the Map Window. 
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4.4.5 Generate the digital terrain (Bathymetry in form of a grid data) 

The base data for any MOHID Water model is the digital terrain (or bathymetry), which 

is provided in form of a Grid Data file. More information about MOHID’s Grid Data 

format can be found here: 

http://www.mohid.com/wiki/index.php?title=Grid_Data 

MOHID Studio contains several tools to create and manipulate grid data files.  

Now, to create the bathymetry we will need three data sets: 

• XYZ points (Tagus_bath_points.xyz - already loaded) 

• Definition of the non-compute areas (CoastLine.xy - already loaded) 

• The computational grid (TagusGrid – created in the previous step) 

To create the grid data we will use the “Grid Data” -> “Construct from Points” tool. 

Double click the tool to open it, as shown in the next figure: 

 

Figure 4.14: The Construct Grid Data Tool 

We will know construct the bathymetry with the following options indicated in the 

following table. 
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Parameter Value Description 

Grid Tagus Grid The grid which is to be used to create the grid data. 

XYZ Points Tagus_bath_points The point dataset(s) which are to be used to fill the 

grid. In this example we only have one, but you can 

use multiple XYZ files. 

Polygons CoastLine (check it!) The polygon(s) which define non compute areas (land 

in the case of MOHID Water). The model will not 

compute any values in the cell covered by these 

polygons. 

XYZ Offset 10% Offset from the grid, in percentage, of the maximum 

distance from the “XYZ Points” are considered when 

using interpolation algorithms. 

Fill Value -99.0 The value to be attributed in non-compute areas. You 

should not change this value unless you have a 

specific reason for. 

XYZ in NCA Leave uncheck If you want to consider a specific height in the non-

compute areas for the interpolation process near the 

land-water interface. 

Interpolation Triangulation The interpolation method you want to use. If the 

density of points is smaller than the number of grid 

cell (not every cell contains a XYZ Point), then this 

option is the recommended one. 

Grid Data C:\MOHID Water Quick Start 

Guide\Projects\Tagus 

2D\General Data\Digital 

Terrain\ 
TagusBathymetry_v01.dat 

The name of the file which will be created. It’s 

recommended to place this file inside the folder 

General Data\Digital Terrain of your project. 

After filling all data, choose the process button ( ) to generate the bathymetry. This 

process might take a couple of minutes and it finished with a status message. 

 

Figure 4.15: Status message of the Construct Grid Data Tool 
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Close the status message and the tool window (using the x). Your main window should 

now like the one in the following figure. 

 

Figure 4.16: Window after creation of the bathymetry 

4.4.6 Edit and verify the bathymetry 

After creating the bathymetry with the tool with must check if the created file is suited 

for MOHID, namely regarding two points: (i) are all boundary cells correctly defined, (ii) 

are there disconnected areas. 

The first point we have to address by editing the bathymetry. The second point can be 

correctly automatically by the model. 

Please note that, points where you want to impose tide must be open (no land point 

between the bathymetry and the border) and points where you don’t want to impose 

tide must be closed (a land point between water and the border). We will now use the 

Edit Grid Data tool to modify an inconsistency at the boundary right border of our 

bathymetry. 

For simplicity we switch off the layers “LandAreaPolygon” and 

“TagusBathymetryPoints” by unchecking them from the “Layers” list. 
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Now we zoom into the problematic area, using the map tool box 

 in the map window, as shown in the next figure. 

 

After zooming in, your screen should look like: 
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As you see, close to the border of the grid there is an open point. If we wouldn’t 

change the bathymetry the model would impose tide here, which is wrong since at this 

border ends the Tagus River. So we will close this point using the “Edit Grid Data Tool”. 

Open the “Edit Grid Data Tool” from the tool menu. 

 

Leave all options as default and use the select area button ( ) to select the grid cell 

at the open boundary (you might find it useful to adjust your zoom level). 
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If you select wrong points you can always use the buttons “Clear Selected Point” ( ) 

or “Clear All Points” ( ). 

Once you have selected the correct point (I = 164, J = 270) select from 3.Operations 

Operation = Close Points and hit the process button. 

 

The color of the select point will disappear and a value of -99 is assigned, which means 

that this point is now closed. 

Under “4. Persist Changes” press the save button ( ) to save and close the tool. 

We are done with preparing the bathymetry. 
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4.5 Step 3 – Generate Tide 

One of the main drivers for water circulation in coastal areas is tide and in almost 

every coastal simulation you probably want to use tide as boundary conditions. MOHID 

Water receives tide as boundary condition through a specific file which contains the 

harmonic components of the tide. 

FES (finite element solution) tide model is the most common source of tidal 

components being available for the entire world and MOHID Studio incorporates a tool 

to obtain harmonic tidal component from FES (version 2004), which data base you 

downloaded during the preparation process. 

We will know generate a simple tidal file, with a single tidal gauge, to be used our 

simulation. From the tool box choose “MOHID Water”->”Generate Tidal File”. You 

window should now look like the one in the following figure. 

 

Figure 2-4.17: Tidal Tool window 

Use the pick button ( ) and select a point near the lower left origin of the 

bathymetry and use the following options under 3. Config Tide: 
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Parameter Value Description 

Grid Tagus Grid The grid which is to be used to create the grid data. 

Tide nc. Path C:\MOHID Water Quick Start 

Guide\tide.fes2004.nc 

Path to the file which contains the global tide 

solution. Downloaded during the preparation. 

Time Ref. 0.0 The time difference between the area you are 

running the model and UTC (e.g. Portugal (0), Spain 

(1)) 

Ref. Level 2.08 Difference between the hydrographic zero and the 

mean sea level. In the area of the example it’s 2.08m 

Output File C:\MOHID Water Quick Start 

Guide\Projects\Tagus 

2D\General Data\Boundary 

Conditions\Tide_x.dat 

The file which will contain the tidal harmonics in in 

MOHID format. You should always place this file in 

the General Data\Boundary Condition folder of your 

project. 

XYZ File C:\MOHID Water Quick Start 

Guide\Projects\Tagus 

2D\General Data\Boundary 

Conditions\TidePoints.xyz 

File with the coordinates which you used. Useful if 

you are using multiple gauges. 

After filling all data, choose the process button ( ) to generate the tide files. This 

process finishes with a status message. 

 

Figure 4.18: Status message of the Tidal Tool 

Close the status message and the tool window (using the x). 

Please note that in real applications you want to use multiple tides as boundary 

conditions (instead of a single one), placing all tides in a triangular way along the open 

boundary, as described here: 

http://www.mohid.com/wiki/index.php?title=How_to_generate_tide_for_Mohid%3F 

Now we finished steps 3 and are ready to create our first simulation. 
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4.6 Step 4 – Associate the domain with the bathymetry 

In step 1 we created a new workspace, solution and a domain. In step 2 we created the 

bathymetry. We will now associate the domain with the bathymetry (this is needed 

because you may have more than on bathymetry). To do so, please switch back to the 

Explorer Window, select the domain “Tagus 2D”, right click and choose “Properties”. 

 

Figure 4.19: Accessing the properties of the domain 

A window with the properties of the domain will show. Under “Digital Terrain”, browse 

for the bathymetry you created earlier (C:\MOHID Water Quick Start 

Guide\Projects\Tagus 2D\General Data\Digital Terrain\TagusBathymetry_v01.dat) as 

shown in the next figure. 
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Figure 4.20: Associating the bathymetry to the domain. 

Now close the window. 

4.7 Step 5 – Create a new simulation 

So far we created the basic input files which are need to run any MOHID Water model. 

We will now create a simulation and fill the compute options for all modules. 

In the Explorer Window select again the domain “Tagus 2D” right click and select 

“Insert Simulation”. A window with the properties of a new simulation will appear. In 

the window you have to provide a name of the simulation, a small description and 

choose which modules you want to activate. 
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Figure 4.21: Creating a new simulation 

Without changing any option, press OK to close the window. A new simulation is 

created and will appear in the project tree. When you select this simulation, the 

module data files will appear. 

 

Figure 4.22: Explorer Window after creating a new simulation 
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4.8 Step 6 – Define the simulation properties 

Selecting the simulation you just created shows that it has several input files listed in 

the “Modules” section and in “Data Files”. In these files we have to specify the options 

for each module. Main files have already default options and here we will only change 

the files which require modification. 

4.8.1 Step 6.1 – Define general simulation options 

The simulation start, end and time step is provided in the file Model_X.dat where is X 

is the simulation number (e.g. Model_1.dat). Under “Modules” double click the file 

“Model_1.dat”, which will open in the file editor. 

 

Figure 4.23: Model_1.dat in the File Editor 

Change the values to the following options (You should avoid using TABs). 

Parameter Value Description 

START 
2015 1 1 0 0 0 Start instant of the simulation. Values are year, 

month, day, hour minute and second. 

END 2015 1 2 0 0 0 End instant of the simulation. Values are year, 

month, day, hour minute and second. 

DT 60.0 Time step of the model, in seconds. 

VARIABLEDT 0 If a variable DT is to be used. 0 to switch off, 1 to 

switch on. For simulations with tide it does not make 

sense to switch this option on (generally only used by 

MOHID Land). 

MAXDT For variable DT only Maximum DT if variable time step is used. 
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GMTREFERENCE 0 Has the same as the time reference as in the tidal 

tool. If running the model in a place other than in 

GTM + 0 than need to edit accordingly (positive to 

east and negative to west). 

DT_PREDICTION_INTE

RVAL 

15.0 Interval, in seconds, when progress notifications are 

displayed. 

 

After editing the file and changing the values as shown in the table above, save and 

close the file by pressing close button. 

 

Figure 4.24: Saving and closing a file in the file editor 

4.8.2 Step 4.3 – Define tidal components 

The information on the tidal components with info separated by gauges is provided in 

file Tide_X.dat where is X is the simulation number (e.g. Tide_1.dat). We have to 

replace the information in this file with the information generated during Step 3 – 

Generate Tide. To do so, we do the following: double click the file Tide_1.dat under 

“Modules” to open the tidal file. Then we navigate in the explorer to Tagus 2D -> 

General Data -> Boundary Conditions, where we stored the file Tide_X.dat. Double 

click to also open this file. We now have both files open in the file editor, as shown in 

the next figure. 
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 Figure 4.25: Opening 2 files in the file editor. 

We now select the entire content in the file Tide_x.dat (by pressing Ctrl+A) and copy it 

(by pressing Ctrl+C). Then we switch to the file Tide_1.dat and select the entire content 

(Ctrl+A) and replace it with the content from the first file (Ctrl+V). Now close and save 

the file Tide_1.dat and close the file Tide_x.dat. 

Under the Project Tree select again the simulation “Sim #1”. 

4.8.3 Step 4.4 – Define hydrodynamic options 

The options of the hydrodynamic module are provided in the file Hydrodynamic_x.dat 

(e.g. Hydrodymamic_1.dat). Double click the file to open it in the File Editor.  

Change the values to the following options (You should avoid using TABs). 

Parameter Value Description 

TIDE 1 If tide is to be considered at the open boundary. 1- 

Yes, 0 – No 

WIND 0 If the effect of wind is to be considered. 1- Yes, 0 – 

No 

WATER_DISCHARGES 0 If the effect of water discharges (e.g. riveres) is to be 

considered. 1- Yes, 0 – No 

BAROCLINIC 0 If the effect of baroclinic forces are to be considered 

(3D only). 1- Yes, 0 – No 

CONTINUOUS              0 If this simulation is a continuation from a previous 

simulation. 1- Yes, 0 – No 
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INITIAL_ELEVATION        0 If an initial elevation should be considered (only 

when running without tide or in sub-models). 1- Yes, 

0 – No 

SLOWSTART 43200 Time to gradually increase the tide water level at the 

open boundary to its full value. This will start the 

model smoothly (recommended value is 86400). In 

seconds.  

INITIAL_ELEVATION_

VALUE 

- Value of the initial elevation. Only read if previous 

value is 1. 

TIME_SERIE               0 If we want to create time series outputs 

TIME_SERIE_LOCATIO

N 

- Path to a file which contains a list of grid points 

where the model should make outputs. Only read if 

previous option is 1 

OUTPUT_TIME 0 3600 Output frequency of map outputs. First instant and 

frequency between outputs. In seconds. 

Once done, save and close the file. 

4.8.4 Step 4.5 – Define turbulence parameters in Turbulence file 

The horizontal and vertical viscosities are specified in the file Turbulence_X.dat (this 

case Turbulence_1.dat). Double click the file to open it in the File Editor. 

Change the values to the following options. 

Parameter Value Description 

VISCOSITY_H 30.0 Horizontal viscosity in m2/s. Good initial guess is 10% 

* (grid size (in m) * average velocity). 

VISCOSITY_V 0 Vertical viscosity in m2/s. 3D simulations only. 

Once done, save and close the file. 

4.8.5 Step 4.6 – Other Files 

Other files which are included in this simulation are not needed to be changed, since 

the default values are acceptable for this first simulation.  
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4.9 Step 7 – Run the simulation and explore results 

Everything now is prepared to run the simulation. In the Explorer Window select the 

simulation Sim #1 and then select the option “Project” -> “Run Now” from the main 

menu (further details have been described earlier). In the message box which appears, 

click “Yes” to start the run. 

When the model finishes, a message box will pop, asking if you would like to see the 

model results. Click “Yes” and a window like the one shown in the next figure will be 

shown. 

 

After any simulation, you should scroll down to the end of the window, checking the 

final status message, as shown in the next figure. 
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In this case the model log tells us that a new bathymetry has been created (isolate cells 

have been removed). This type of message can appear in a set of occasions and we 

must address them in order to get the model running from start to end. 

In this particularly case we have to change the bathymetry from: 

C:\MOHID Water Quick Start Guide\Projects\Tagus 2D\General Data\Digital Terrain\TagusBathymetry_v01.dat 

to: 

C:\MOHID Water Quick Start Guide\Projects\Tagus 2D\General Data\Digital Terrain\TagusBathymetry_v02.dat 

So we will close the model output window and select the domain “Tagus 2D” in the 

Explorer Window. Through a right mouse click we can access the properties of the 

domain (as described earlier). Change the digital terrain to the new file created by the 

model, as shown in the next figure. 
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Close this window and run the simulation again, by selecting “Sim #1” in the Project 

Tree and then pressing “Run Now” in the main menu. The simulation now should start 

and work properly. Progress is indicated in the progress window. Wait and until the 

simulations finishes.  

You can know explore the results by adding layers to the map, as described in section 

3.6. 

You will not see any time series results (as shown in section 3.6), so in the next step we 

will change the configuration of this model in a way that also time series are written. 

4.10 Step 8 – Add time series output and rerun the model 

Time series output is complementary to the map output. In order to create time series 

output you have to create a file with the points where you want to make time series 

output. This can be done with the tool “Grid Location”. 
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With this tool use the “Add Points” button ( ) to add new places. Select one place at 

the mouth of the estuary and another one inside the estuary. Then also select the 

“Save also as XML Geometry” option. Your screen should now look like: 

 

Now save all information, by pressing the “Save Button” ( ), using the following 

path: 

C:\MOHID Water Quick Start Guide\Projects\Tagus 2D\General Data\TimeSeriesLocation.dat 

After saving the tool window will close and the layer with the marks will be removed. 



M O H I D  W a t e r  Q u i c k  S t a r t  

 
A c t i o n  M o d u l e r s  -  w w w . a c t i o n m o d u l e r s . c o m  5 6  

 

Now we will switch to the explorer window, select the simulation “Sim #1” and open 

the Hydrodynamic_1.dat file (by double clicking it). Change the following options in 

this file. 

Parameter Value Description 

TIME_SERIE 1 If time series output is to be written. 1- Yes, 0 – No 

TIME_SERIE_LOCATIO

N 

..\General 

Data\TimeSeriesLocation.dat 

Path to the file with the point locations. 

Once done, save and close the file. 

Now you can rerun the model, following the steps defined in the previous chapter. 

Once the model is finished, time series results should appear in the Explorer Window, 

as shown in the next figure. 

 

You can now open and see these results, following the steps described in 3.6.  
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5 Exercise 3 – Exploring Additional Examples 

5.1 Introduction 

In Exercise 1 we downloaded a previously created model setup and imported it into 

MOHID Studio. The goal was to learn a little bit how MOHID Studio works. 

In Exercise 2 we created a new model setup from scratch using some basic data files. 

The goal of the second exercise was to learn the basic steps you need to setup a simple 

2D MOHID Water simulation. 

MOHID Water has hundreds of options, so sometimes it’s tricky to find the right option 

for all the data files. In this exercise, Exercise 3, we will show how to open existing 

online resources which you can use as guidance to setup you own model.  

5.2 Step 1 – Startup Page 

MOHID Studio’s Start-up page has on the right side a set of online resources, which we 

update frequently. To access the start page, select Home -> Links -> Start. 

 

This page is allows shown after start up but, by default, it closes after opening a work 

space. You can change this behaviour in the lower left corner of the Start-up page. 
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We will now select a more advanced sample of the Tagus Estuary, which contains 

different types of simulations. 

5.3 Step 2 – Download and open advanced examples 

In the Startup Page check for the resource “Example Simulations in the Tagus Estuary, 

including hydrodynamics, transport and water quality”, as indicated in the figure 

below. 

 

Click on this line. 

A popup window will appear which asks for where to store this example.  
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Create a directory in c:\MOHID Water Quick Start Guide\Projects called “Tagus 

Advanced” and press OK. 

The download of the sample will start automatically. Once the download is completed 

(a message box informs you about this) your current workspace is closed and the 

download example is opened automatically. Your window should now look like the one 

indicated next. 
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Inside this example you will find a set of simulations, showing different features of 

MOHID Water. We recommend that you run and explorer these examples. 

The first 5 simulations are the same which were already in Exercise 1. Please check the 

following observations. 

Name Objective Observations 

Sim #1 Simple 2D simulation. Forcing 

the model with tide.  

Data files very similar to Exercise 2. 

Sim #2 Simple 3D simulation, using 3 

layers. Forcing the model with 

tide and a river discharge.  

Added heat and salinity 

transport. 

Data files show how to implement some more 

advanced features in MOHID Water. Transport of 

properties (Waterproperties_2), vertical layers 

(Geometry_2), full vertical turbulence model 

(Turbulence_v2 & GOTM_v2) and discharges from 

rivers (Discharges_v2 & Hydrodynamic.dat) 

Sim #3 Same as previous, but added 

wind forcing and other 

atmospheric fluxes and also 

sediment transport 

Data files show how to implement some even more 

advanced features in MOHID Water. Atmospheric 

boundary conditions for wind and heat transfer 

(Atmosphere_v3 and InterfaceWaterAir_v3) and 

transport of sediments (FreeVerticalMovement_v3, 

Waterproperties_3 and InterfaceSedimentWater_v3) 

and  

Sim #4 Same as previous, but added 

discharges from a WWTP to 

simulate fecal coliforms 

Data files show how to activate the lagrangian model 

(Lagrangian_v4 and Model_v4) 

Sim #5 Same as previous, but added 

water quality simulation 

(phosphorus and nitrogen) 

Data files show how to activate the water quality 

module in MOHID Water using a Eulerian approach 

(Waterproperties_v5 and Waterquality_v5) 
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Besides the simulation listed in the table above, the example contains a set of 

simulations nested in the “Spin up 2D” simulations. 

Whenever you want to setup a MOHID Water model in your site, you can use these 

examples as guidance. Basic steps are: 

1. Create a new domain, including computational grid and bathymetry, as shown 

in step 2; 

2. Copy data files from the examples the new created domain; 

3. Adopt the data files where needed. 

There are 2 features in MOHID Studio which you might find particularly interesting: the 

option to compare data files between simulations (Project -> Simulations -> Compare) 

and to copy data files from one Project/Simulation to another (Project -> Simulation -> 

Copy). 

 

Please check MOHID Studio’s User Guide for further information. 

6 Final Remarks  

This quick start-guide to implement MOHID Water intends to help first time users to 

quickly get the model running but may also be a starting point for every new 

implementation. The implementation of MOHID Water in these terms, with increasing 

complexity and processes added in cumulative way, gives user the sensibility to the 

major factors affecting circulation and water quality for each implementation site. 

Any difficulties or need for more developed information should be addressed in the 

MOHID channels mentioned at the start of this document. 

We appreciate all feed-back that you may give us on the implementation of MOHID 

Water projects with MOHID Studio so that this guide can improve with time. 


